728*90

User Tag List

Results 1 to 2 of 2

Thread: Bad experience with FLJ T113 scooter

  1. #1

    Bad experience with FLJ T113 scooter

    Join Date
    Mar 2019
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    0 Not allowed! Not allowed!

    Angry Bad experience with FLJ T113 scooter

    250*250-1
    After watching and trying a work partner's Nacotech superscooter (similar to Dualtron) I got the superscooter fever and bought a FLJ T113 at the end of last summer for going to work daily.
    It was great a experience the firtst 2 months: I had a super powered scooter that could travel through the bike ways and streets limited to 30km/h through Barcelona.
    One morning on the way to work, suddenly switched off and could not switch on anymore, even the battery was charged again to 100% and lights/horn/blocking system were working good...
    After chating several times with the seller and send them photos/videos, they told me it probably was a problem from LCD screen and blocking system (alarm), so they sent me new components that I replaced myself, because they don't have support or aftersales deppartment here in Spain.
    After replacing them nothing changed, so I told them and then sent me new pair of controllers. After receiving and replacing them, couldn't switch on, but after checking all the cables finally was able to switch on again and gave me some hope, but the battery gets out of charge in 1 minute and doesn't charge anymore. Now the charger light blinks green to red while charging, so looks like a battery issue that can't be fixed by any scooter workshop because there are no components for them...
    I hope to get soon a new battery+charger and be able to ride again my already 4-months-stopped-expensive-scooter...
    Last edited by cesarmt; 03-04-2019 at 02:50 PM.

  2. #2

    Bad experience with FLJ T113 scooter

    Join Date
    Mar 2019
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    0 Not allowed! Not allowed!
    Finally I'm glad to say I can ride my T113 again...
    After replacing LCD, alarm blocking system, 2 controllers, batery BMS controller, battery... finally I brought it to a scooter workshop and they told me it was a LCD problem (already replaced), so I asked for a new one to the seller and now is working right again, more or less, because the gas trigger fails sometimes... I hope to get it solved soon.
    Last edited by cesarmt; 07-30-2019 at 03:27 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •